summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:53:28 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 21:03:12 +0900
commitcd0bca7c4bfa7db7de3417fd9da3fcdc50114b8a (patch)
tree8e590c46a2cf88268060dc5f553f3be236871c82 /CMakeLists.txt
parentffaff7d76a96cbf3b3cf51e606396641482a76e3 (diff)
downloadknights-cd0bca7c4bfa7db7de3417fd9da3fcdc50114b8a.tar.gz
knights-cd0bca7c4bfa7db7de3417fd9da3fcdc50114b8a.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit e04582c215ce22ce199f012681c4cda4134f2ec2)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5098df9..7a95199 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )