summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2019-11-01 11:46:21 +0100
committergregory guy <gregory-tde@laposte.net>2019-11-01 11:46:21 +0100
commit873d0e4138a1569d2a8dfa061d0338b6d017dd3b (patch)
tree330519cff76d1948c74f7674793cdc1399fee3d6 /Makefile.am
parent620d83c4efc5ffcbf89d941410dbddda4daff279 (diff)
downloadknights-873d0e4138a1569d2a8dfa061d0338b6d017dd3b.tar.gz
knights-873d0e4138a1569d2a8dfa061d0338b6d017dd3b.zip
Drop automake build support.
Add basic cmake build instructions in the INSTALL file. Rework of README file and the help page. The History file has been removed, the content added to the ChangeLog file. The file CreatingThemes has moved in the doc folder. Cosmetic changes in CMakeLists.txt . Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am54
1 files changed, 0 insertions, 54 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index f046d53..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,54 +0,0 @@
-####### tdevelop will overwrite this part!!! (begin)##########
-
-SUBDIRS = doc knights media po
-
-####### tdevelop will overwrite this part!!! (end)############
-# not a GNU package. You can remove this line, if
-# have all needed files, that a GNU package needs
-AUTOMAKE_OPTIONS = foreign
-
-$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
- cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
-
-$(top_srcdir)/subdirs:
- cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
-
-$(top_srcdir)/acinclude.m4: $(top_srcdir)/admin/acinclude.m4.in $(top_srcdir)/admin/libtool.m4.in
- @cd $(top_srcdir) && cat admin/acinclude.m4.in admin/libtool.m4.in > acinclude.m4
-
-MAINTAINERCLEANFILES = subdirs configure.in acinclude.m4 configure.files
-
-package-messages:
- $(MAKE) -f admin/Makefile.common package-messages
- $(MAKE) -C po merge
-
-dist-hook:
- cd $(top_distdir) && perl admin/am_edit -padmin
- cd $(top_distdir) && $(MAKE) -f admin/Makefile.common subdirs
-
-rpm_prep: doc clean distclean-generic ${PACKAGE}.spec
- rm -R -f /tmp/${PACKAGE}-@RPM_VERSION@
- mkdir -p /tmp/${PACKAGE}-@RPM_VERSION@
- (cd ${srcdir} ; cp -R -a ./* /tmp/${PACKAGE}-@RPM_VERSION@ )
- (cd /tmp/ ; \
- touch ${PACKAGE}-@RPM_VERSION@/doc/help_{en,de,fr,et}.docbook ; \
- find ${SRC_PREFIX}-@RPM_VERSION@ -name CVS > \
- /tmp/${PACKAGE}-tar-excludes.lst ; \
- find ${SRC_PREFIX}-@RPM_VERSION@ -name Makefile \
- -o -name Makefile.in >> \
- /tmp/${PACKAGE}-tar-excludes.lst ; \
- echo "${SRC_PREFIX}-@RPM_VERSION@/doc/api" >> \
- /tmp/${PACKAGE}-tar-excludes.lst ; \
- tar --exclude-from=/tmp/${PACKAGE}-tar-excludes.lst \
- -chzf ${PACKAGE}-@RPM_VERSION@.tar.gz \
- ${SRC_PREFIX}-@RPM_VERSION@ ; \
- rm -f /tmp/${PACKAGE}-tar-excludes.lst )
- rm -R -f /tmp/${PACKAGE}-@RPM_VERSION@
-
-# does not work with original SuSE-6.4 rpm
-# you will need an update of the rpm package !
-rpm: rpm_prep
- rpm -ta /tmp/${PACKAGE}-@RPM_VERSION@.tar.gz
-
-src.rpm: rpm_prep
- rpm -ts /tmp/${PACKAGE}-@RPM_VERSION@.tar.gz