summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am54
1 files changed, 54 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..24a78b1
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,54 @@
+####### kdevelop will overwrite this part!!! (begin)##########
+
+SUBDIRS = admin doc knights media po
+
+####### kdevelop will overwrite this part!!! (end)############
+# not a GNU package. You can remove this line, if
+# have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign
+
+$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
+ cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
+
+$(top_srcdir)/subdirs:
+ cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
+
+$(top_srcdir)/acinclude.m4: $(top_srcdir)/admin/acinclude.m4.in $(top_srcdir)/admin/libtool.m4.in
+ @cd $(top_srcdir) && cat admin/acinclude.m4.in admin/libtool.m4.in > acinclude.m4
+
+MAINTAINERCLEANFILES = subdirs configure.in acinclude.m4 configure.files
+
+package-messages:
+ $(MAKE) -f admin/Makefile.common package-messages
+ $(MAKE) -C po merge
+
+dist-hook:
+ cd $(top_distdir) && perl admin/am_edit -padmin
+ cd $(top_distdir) && $(MAKE) -f admin/Makefile.common subdirs
+
+rpm_prep: doc clean distclean-generic ${PACKAGE}.spec
+ rm -R -f /tmp/${PACKAGE}-@RPM_VERSION@
+ mkdir -p /tmp/${PACKAGE}-@RPM_VERSION@
+ (cd ${srcdir} ; cp -R -a ./* /tmp/${PACKAGE}-@RPM_VERSION@ )
+ (cd /tmp/ ; \
+ touch ${PACKAGE}-@RPM_VERSION@/doc/help_{en,de,fr,et}.docbook ; \
+ find ${SRC_PREFIX}-@RPM_VERSION@ -name CVS > \
+ /tmp/${PACKAGE}-tar-excludes.lst ; \
+ find ${SRC_PREFIX}-@RPM_VERSION@ -name Makefile \
+ -o -name Makefile.in >> \
+ /tmp/${PACKAGE}-tar-excludes.lst ; \
+ echo "${SRC_PREFIX}-@RPM_VERSION@/doc/api" >> \
+ /tmp/${PACKAGE}-tar-excludes.lst ; \
+ tar --exclude-from=/tmp/${PACKAGE}-tar-excludes.lst \
+ -chzf ${PACKAGE}-@RPM_VERSION@.tar.gz \
+ ${SRC_PREFIX}-@RPM_VERSION@ ; \
+ rm -f /tmp/${PACKAGE}-tar-excludes.lst )
+ rm -R -f /tmp/${PACKAGE}-@RPM_VERSION@
+
+# does not work with original SuSE-6.4 rpm
+# you will need an update of the rpm package !
+rpm: rpm_prep
+ rpm -ta /tmp/${PACKAGE}-@RPM_VERSION@.tar.gz
+
+src.rpm: rpm_prep
+ rpm -ts /tmp/${PACKAGE}-@RPM_VERSION@.tar.gz