summaryrefslogtreecommitdiffstats
path: root/knights/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'knights/CMakeLists.txt')
-rw-r--r--knights/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/knights/CMakeLists.txt b/knights/CMakeLists.txt
index e3239d9..9e7b739 100644
--- a/knights/CMakeLists.txt
+++ b/knights/CMakeLists.txt
@@ -44,12 +44,10 @@ tde_add_executable( ${PROJECT_NAME} AUTOMOC
##### other data
-install(
- FILES pgn.desktop
- DESTINATION ${MIME_INSTALL_DIR}/application
-)
+tde_create_translated_desktop( ${PROJECT_NAME}.desktop )
-install(
- FILES ${PROJECT_NAME}.desktop
- DESTINATION ${APPS_INSTALL_DIR}/Games/Board
+tde_create_translated_desktop(
+ SOURCE pgn.desktop
+ DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/pgn-mimetype
)