summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:55:23 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 21:04:47 +0900
commit750d9ef37aa3b6dc015349f6a1b684fe04f8179a (patch)
treef0fa9cc97c90f943790d48ff8e8ae191b6f2b9ad /CMakeLists.txt
parent94758dbe7bb5b3f5cc63366ba43d951a13802438 (diff)
downloadknmap-750d9ef37aa3b6dc015349f6a1b684fe04f8179a.tar.gz
knmap-750d9ef37aa3b6dc015349f6a1b684fe04f8179a.zip
Use centralized cmake versionr14.1.2
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit c4773bb18726950f9a120daab6786477eff484ef)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2c62172..27ff79c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )