summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-10-16 01:30:23 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-10-16 01:34:23 +0200
commite2ca425f12e15b852b7e75f61d0d5b6923417725 (patch)
treefd5b89784c8c6a618b149e33283b660819b29e1a /CMakeLists.txt
parent487b3ad8964838a72f01b18a364dd9b7036b237e (diff)
downloadknutclient-e2ca425f12e15b852b7e75f61d0d5b6923417725.tar.gz
knutclient-e2ca425f12e15b852b7e75f61d0d5b6923417725.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 54bb877d9058412680ae04433ebd34cadfa1e78e)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e780f8c..253701c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )