summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2019-12-30 14:08:45 +0100
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-01-01 22:41:54 +0900
commitf8ac80fc16dfbe3efeb16c77522242883026305c (patch)
tree7df427652609c7b9c12cba0bde50b742d2238a5e /src/Makefile.am
parentbb2c3b93bbb9a3f8b9ae96ba9a6034affc0fd000 (diff)
downloadknutclient-f8ac80fc16dfbe3efeb16c77522242883026305c.tar.gz
knutclient-f8ac80fc16dfbe3efeb16c77522242883026305c.zip
Drop automake build support.
Add basic build instructions to the INSTALL file. Remove empty files NEWS and TODO. Remove "specs" folder as well as several shell scripts (Deb, Fedora, Mandriva...) Rework of the REAME file and the help page. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit 6ca05fe5e859a5f276453085fe4d89e662741a54)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am41
1 files changed, 0 insertions, 41 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 0974671..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,41 +0,0 @@
-# set the include path for X, qt and KDE
-INCLUDES = $(all_includes)
-
-# these are the headers for your project
-noinst_HEADERS = knutclient.h knutmainwindow.h knutprefdlg.h knutnewupsdlg.h \
- knutupsdata.h knutvardata.h knutnet.h knutfrontpanel.h knutpanelmeter.h knutdock.h \
- knutprintupsvar.h knutinstcomms.h knutrwvar.h knutanalog.h knutmessagemanager.h \
- knutmessage.h
-
-# let automoc handle all of the meta source files (moc)
-METASOURCES = AUTO
-
-messages: rc.cpp
- $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
- $(XGETTEXT) *.cpp -o $(podir)/knutclient.pot
-
-KDE_ICON = AUTO
-
-#########################################################################
-# APPLICATION SECTION
-#########################################################################
-# this is the program that gets installed. it's name is used for all
-# of the other Makefile.am variables
-bin_PROGRAMS = knutclient
-
-# the application source, library search path, and link libraries
-knutclient_SOURCES = main.cpp knutclient.cpp knutmainwindow.cpp knutprefdlg.cpp \
- knutnewupsdlg.cpp knutupsdata.cpp knutvardata.cpp knutnet.cpp knutfrontpanel.cpp \
- knutpanelmeter.cpp knutdock.cpp knutprintupsvar.cpp knutinstcomms.cpp knutrwvar.cpp \
- knutanalog.cpp knutmessagemanager.cpp knutmessage.cpp
-knutclient_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
-knutclient_LDADD = $(LIB_TDEUI)
-
-# this is where the desktop file will go
-shelldesktopdir = $(kde_appsdir)/Utilities
-shelldesktop_DATA = knutclient.desktop
-
-# this is where the shell's XML-GUI resource file goes
-shellrcdir = $(kde_datadir)/knutclient
-shellrc_DATA = knutclientui.rc
-