summaryrefslogtreecommitdiffstats
path: root/chalk/plugins/viewplugins/performancetest/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-06-13 08:37:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2012-06-13 08:37:52 +0200
commit5c69fcd39111465de16c933763d3c918703048d8 (patch)
treeccd0a0cf7e7d30a8ebe16a71e7e26ede6ee7a66c /chalk/plugins/viewplugins/performancetest/Makefile.am
parent17477649bd724528a78e6c772244dc1a63f38202 (diff)
downloadkoffice-5c69fcd39111465de16c933763d3c918703048d8.tar.gz
koffice-5c69fcd39111465de16c933763d3c918703048d8.zip
Fix FTBFS due to missing libraries
Clean up lib paths in LDFLAGS - moved to LIBADD For KWord and and KPresenter added linking kspell2 For KSpread added linking kutils This closes Bug 657
Diffstat (limited to 'chalk/plugins/viewplugins/performancetest/Makefile.am')
-rw-r--r--chalk/plugins/viewplugins/performancetest/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/chalk/plugins/viewplugins/performancetest/Makefile.am b/chalk/plugins/viewplugins/performancetest/Makefile.am
index 52cafd70..32da2ec3 100644
--- a/chalk/plugins/viewplugins/performancetest/Makefile.am
+++ b/chalk/plugins/viewplugins/performancetest/Makefile.am
@@ -16,9 +16,11 @@ kde_module_LTLIBRARIES = chalkperftest.la
chalkperftest_la_SOURCES = wdg_perftest.ui perftest.cc dlg_perftest.cc
noinst_HEADERS = wdg_perftest.h dlg_perftest.h perftest.h
-chalkperftest_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) chalkblurfilter_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -ltdecore -ltdeui -lkjs -ltdefx -lkio -lkparts -L../../../../chalk/chalkcolor/.libs -lchalkcolor -L../../../../chalk/core/.libs -lchalkimage \
- -L../../../../chalk/ui/.libs -lchalkui -L../../../../lib/kofficeui/.libs -lkofficeui
-chalkperftest_la_LIBADD = ../../../libchalkcommon.la
+chalkperftest_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) chalkblurfilter_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -ltdecore -ltdeui -lkjs -ltdefx -lkio -lkparts
+chalkperftest_la_LIBADD = $(LIB_KOFFICEUI) ../../../libchalkcommon.la \
+ ../../../../chalk/chalkcolor/libchalkcolor.la \
+ ../../../../chalk/core/libchalkimage.la \
+ ../../../../chalk/ui/libchalkui.la
kde_services_DATA = chalkperftest.desktop