summaryrefslogtreecommitdiffstats
path: root/kformula/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /kformula/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kformula/Makefile.am')
-rw-r--r--kformula/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/kformula/Makefile.am b/kformula/Makefile.am
new file mode 100644
index 00000000..e291a340
--- /dev/null
+++ b/kformula/Makefile.am
@@ -0,0 +1,41 @@
+INCLUDES = $(KOFFICE_INCLUDES) $(KFORMULA_INCLUDES) $(KOTEXT_INCLUDES) -I$(interfacedir) $(all_includes)
+KDE_CXXFLAGS = $(USE_RTTI)
+
+## The part
+kde_module_LTLIBRARIES = libkformulapart.la
+libkformulapart_la_SOURCES = kformula_doc.cc \
+ kformula_view.cc kformula_factory.cc kformulawidget.cc kfconfig.cc \
+ kformula_view_iface.skel kformula_view_iface.cc formulastring.cc fsparser.cc
+libkformulapart_la_LDFLAGS = $(KDE_PLUGIN)
+libkformulapart_la_LIBADD = $(LIB_KOFFICEUI) $(LIB_KFORMULA) $(LIB_KOTEXT)
+libkformulapart_la_METASOURCES = AUTO
+
+## The kdeinit loadable module
+kdeinit_LTLIBRARIES = kformula.la
+kformula_la_SOURCES = main.cc
+kformula_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kformula_la_LIBADD = $(LIB_KOFFICECORE)
+
+bin_PROGRAMS =
+lib_LTLIBRARIES =
+
+noinst_HEADERS = kformula_doc.h \
+ kformula_view.h kformula_factory.h \
+ kformula_aboutdata.h kformula_view_iface.h formulastring.h fsparser.h
+
+xdg_apps_DATA = kformula.desktop
+
+rc_DATA = kformula.rc kformula_readonly.rc
+rcdir = $(kde_datadir)/kformula
+
+SUBDIRS = pics
+
+tipdir = $(kde_datadir)/kformula
+tip_DATA = tips
+
+messages: rc.cpp
+ $(PREPARETIPS) >> rc.cpp
+ $(XGETTEXT) rc.cpp *.cc kformula_aboutdata.h -o $(podir)/kformula.pot
+kde_services_DATA = kformulapart.desktop
+
+include $(top_srcdir)/admin/Doxyfile.am