summaryrefslogtreecommitdiffstats
path: root/kugar/kudesigner_lib/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /kugar/kudesigner_lib/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kugar/kudesigner_lib/Makefile.am')
-rw-r--r--kugar/kudesigner_lib/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kugar/kudesigner_lib/Makefile.am b/kugar/kudesigner_lib/Makefile.am
new file mode 100644
index 00000000..95b8fe00
--- /dev/null
+++ b/kugar/kudesigner_lib/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = $(KOPROPERTY_INCLUDES) $(KOFFICE_INCLUDES) $(all_includes)
+
+# Temporary hack, to work around the KColorCombo bug with --enable-final
+KDE_OPTIONS = nofinal
+
+noinst_LTLIBRARIES = libkudesignercommon.la
+libkudesignercommon_la_LDFLAGS = $(all_libraries)
+libkudesignercommon_la_METASOURCES = AUTO
+libkudesignercommon_la_SOURCES = band.cpp box.cpp calcfield.cpp canvas.cpp \
+ command.cpp commdefs.cpp detailbase.cpp detail.cpp detailfooter.cpp \
+ detailheader.cpp field.cpp kugartemplate.cpp label.cpp line.cpp pagefooter.cpp \
+ pageheader.cpp propertyserializer.cpp reportfooter.cpp reportheader.cpp reportitem.cpp \
+ section.cpp specialfield.cpp structurewidget.cpp view.cpp plugin.cpp
+libkudesignercommon_la_LIBADD = $(LIB_KOPROPERTY)
+
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) -DKPROPERTY_EXPORT=
+