summaryrefslogtreecommitdiffstats
path: root/lib/kross/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /lib/kross/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'lib/kross/Makefile.am')
-rw-r--r--lib/kross/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/lib/kross/Makefile.am b/lib/kross/Makefile.am
new file mode 100644
index 00000000..6e0fa847
--- /dev/null
+++ b/lib/kross/Makefile.am
@@ -0,0 +1,22 @@
+# Compile python plugin only if python is installed. Kross itself doesn't
+# care of it cause it doesn't depend directly on the python plugin. Kross
+# determinates at runtime if it's avaiable and if that's the case it just
+# uses the plugin. So, we are able to don't compile the python plugin now
+# and at a later stage once we like to use it, just compile+install the
+# python plugin and let Kross use it without the need to recompiling whole
+# Kross. So, for packagers it's recommed to move the python plugin into
+# an own package that could be optional installed.
+if compile_kross_python
+ PYTHONSUBDIR = python
+endif
+
+# Also only compile the ruby plugin if ruby is installed.
+if compile_kross_ruby
+ RUBYSUBDIR = ruby
+endif
+
+SUBDIRS = api main $(PYTHONSUBDIR) $(RUBYSUBDIR) runner
+
+# Don't compile test by default. To use test, just cd into the directory
+# and do a "make && ./krosstest" manualy.
+#SUBDIRS += test