summaryrefslogtreecommitdiffstats
path: root/chalk/core/tiles/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'chalk/core/tiles/Makefile.am')
-rw-r--r--chalk/core/tiles/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/chalk/core/tiles/Makefile.am b/chalk/core/tiles/Makefile.am
new file mode 100644
index 00000000..1e334ab4
--- /dev/null
+++ b/chalk/core/tiles/Makefile.am
@@ -0,0 +1,23 @@
+if include_kunittest_tests
+TESTSDIR = tests
+endif
+
+SUBDIRS = . $(TESTSDIR)
+
+INCLUDES = -I$(srcdir)/../ \
+ -I$(srcdir)/../../sdk \
+ $(KOFFICE_INCLUDES) \
+ -I$(interfacedir) \
+ $(all_includes)
+
+noinst_LTLIBRARIES = libchalktile.la
+
+libchalktile_la_SOURCES = kis_tiledvlineiterator.cc kis_tiledhlineiterator.cc \
+ kis_tileddatamanager.cc kis_tile.cc kis_tilediterator.cc kis_tiledrectiterator.cc \
+ kis_memento.cc kis_tilemanager.cc kis_tiled_random_accessor.cc
+
+libchalktile_la_METASOURCES = AUTO
+
+include_HEADERS = \
+ kis_tileddatamanager.h
+noinst_HEADERS = kis_tiled_random_accessor.h