summaryrefslogtreecommitdiffstats
path: root/chalk/plugins/tools/selectiontools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'chalk/plugins/tools/selectiontools/Makefile.am')
-rw-r--r--chalk/plugins/tools/selectiontools/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/chalk/plugins/tools/selectiontools/Makefile.am b/chalk/plugins/tools/selectiontools/Makefile.am
new file mode 100644
index 00000000..dc0ad90e
--- /dev/null
+++ b/chalk/plugins/tools/selectiontools/Makefile.am
@@ -0,0 +1,56 @@
+kde_services_DATA = chalkselectiontools.desktop
+
+# all_includes must remain last!
+INCLUDES = -I$(srcdir)/../../../sdk \
+ -I$(srcdir)/../../../core \
+ -I$(srcdir)/../../../chalkcolor/ \
+ -I$(srcdir)/../../../ui \
+ -I$/../../../ui \
+ $(KOFFICE_INCLUDES) \
+ $(all_includes)
+
+chalkselectiontools_la_SOURCES = kis_tool_move_selection.cc \
+ kis_tool_select_brush.cc kis_tool_select_contiguous.cc kis_tool_select_elliptical.cc \
+ kis_tool_select_eraser.cc kis_tool_select_outline.cc kis_tool_select_polygonal.cc \
+ kis_tool_select_rectangular.cc selection_tools.cc
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = chalkselectiontools.la
+
+noinst_HEADERS = \
+ selection_tools.h \
+ kis_tool_select_outline.h \
+ kis_tool_select_polygonal.h \
+ kis_tool_select_rectangular.h \
+ kis_tool_select_brush.h \
+ kis_tool_select_eraser.h \
+ kis_tool_select_contiguous.h \
+ kis_tool_select_elliptical.h
+
+
+chalkselectiontools_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -lkdecore -lkdeui -lkjs -lkdefx -lkio -lkparts -L../../../../chalk/chalkcolor/.libs -lchalkcolor -L../../../../chalk/core/.libs -lchalkimage \
+ -L../../../../chalk/ui/.libs -lchalkui
+chalkselectiontools_la_LIBADD = ../../../libchalkcommon.la
+
+chalkselectiontools_la_METASOURCES = AUTO
+
+KDE_OPTIONS = nofinal
+
+chalkpics_DATA = \
+ tool_rect_selection.png \
+ tool_eraser_selection.png \
+ tool_brush_selection.png \
+ tool_contiguous_selection.png \
+ tool_elliptical_selection.png \
+ tool_outline_selection.png \
+ tool_polygonal_selection.png \
+ tool_rectangular_selection_cursor.png \
+ tool_eraser_selection_cursor.png \
+ tool_brush_selection_cursor.png \
+ tool_contiguous_selection_cursor.png \
+ tool_elliptical_selection_cursor.png \
+ tool_outline_selection_cursor.png \
+ tool_polygonal_selection_cursor.png
+
+chalkpicsdir = $(kde_datadir)/chalk/pics
+