summaryrefslogtreecommitdiffstats
path: root/chalk/plugins/tools/tool_perspectivetransform/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'chalk/plugins/tools/tool_perspectivetransform/Makefile.am')
-rw-r--r--chalk/plugins/tools/tool_perspectivetransform/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/chalk/plugins/tools/tool_perspectivetransform/Makefile.am b/chalk/plugins/tools/tool_perspectivetransform/Makefile.am
new file mode 100644
index 00000000..416bdcc3
--- /dev/null
+++ b/chalk/plugins/tools/tool_perspectivetransform/Makefile.am
@@ -0,0 +1,35 @@
+kde_services_DATA = chalktoolperspectivetransform.desktop
+
+# all_includes must remain last!
+INCLUDES = -I$(srcdir)/../../../sdk \
+ -I$(srcdir)/../../../core \
+ -I$(srcdir)/../../../chalkcolor/ \
+ -I$(srcdir)/../../../ui \
+ -I$/../../../ui \
+ $(KOFFICE_INCLUDES) \
+ $(all_includes)
+
+chalktoolperspectivetransform_la_SOURCES = \
+ tool_perspectivetransform.cc \
+ kis_tool_perspectivetransform.cc
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = chalktoolperspectivetransform.la
+
+noinst_HEADERS = \
+ tool_perspectivetransform.h \
+ kis_tool_perspectivetransform.h
+
+chalktoolperspectivetransform_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -lkdecore -lkdeui -lkjs -lkdefx -lkio -lkparts -L../../../../chalk/chalkcolor/.libs -lchalkcolor -L../../../../chalk/core/.libs -lchalkimage \
+ -L../../../../chalk/ui/.libs -lchalkui
+chalktoolperspectivetransform_la_LIBADD = ../../../libchalkcommon.la
+
+chalktoolperspectivetransform_la_METASOURCES = AUTO
+
+KDE_OPTIONS = nofinal
+
+chalkpics_DATA = \
+ tool_perspectivetransform.png
+
+chalkpicsdir = $(kde_datadir)/chalk/pics
+