summaryrefslogtreecommitdiffstats
path: root/chalk/plugins/tools/tool_transform/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'chalk/plugins/tools/tool_transform/Makefile.am')
-rw-r--r--chalk/plugins/tools/tool_transform/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/chalk/plugins/tools/tool_transform/Makefile.am b/chalk/plugins/tools/tool_transform/Makefile.am
new file mode 100644
index 00000000..7b088383
--- /dev/null
+++ b/chalk/plugins/tools/tool_transform/Makefile.am
@@ -0,0 +1,37 @@
+kde_services_DATA = chalktooltransform.desktop
+
+# all_includes must remain last!
+INCLUDES = -I$(srcdir)/../../../sdk \
+ -I$(srcdir)/../../../core \
+ -I$(srcdir)/../../../chalkcolor/ \
+ -I$(srcdir)/../../../ui \
+ -I$/../../../ui \
+ $(KOFFICE_INCLUDES) \
+ $(all_includes)
+
+chalktooltransform_la_SOURCES = \
+ wdg_tool_transform.ui \
+ tool_transform.cc \
+ kis_tool_transform.cc
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = chalktooltransform.la
+
+noinst_HEADERS = \
+ tool_transform.h \
+ kis_tool_transform.h
+
+chalktooltransform_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -lkdecore -lkdeui -lkjs -lkdefx -lkio -lkparts -L../../../../chalk/chalkcolor/.libs -lchalkcolor -L../../../../chalk/core/.libs -lchalkimage \
+ -L../../../../chalk/ui/.libs -lchalkui
+chalktooltransform_la_LIBADD = ../../../libchalkcommon.la
+
+chalktooltransform_la_METASOURCES = AUTO
+
+KDE_OPTIONS = nofinal
+
+chalkpics_DATA = \
+ rotate_cursor.xpm \
+ tool_transform.png
+
+chalkpicsdir = $(kde_datadir)/chalk/pics
+