summaryrefslogtreecommitdiffstats
path: root/karbon/plugins/insertknots/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'karbon/plugins/insertknots/Makefile.am')
-rw-r--r--karbon/plugins/insertknots/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/karbon/plugins/insertknots/Makefile.am b/karbon/plugins/insertknots/Makefile.am
index 1e014819..46f350c9 100644
--- a/karbon/plugins/insertknots/Makefile.am
+++ b/karbon/plugins/insertknots/Makefile.am
@@ -3,10 +3,10 @@ INCLUDES = $(KOFFICE_INCLUDES) -I$(top_srcdir)/karbon -I$(top_srcdir)/karbon/co
kde_module_LTLIBRARIES = karbon_insertknotsplugin.la
karbon_insertknotsplugin_la_SOURCES = insertknotsplugin.cc
-karbon_insertknotsplugin_la_LIBADD = $(LIB_KPARTS) \
- ../../libkarboncommon.la
+karbon_insertknotsplugin_la_LIBADD = $(LIB_KPARTS) $(LIB_KOFFICECORE) $(LIB_KOFFICEUI) \
+ $(LIB_KOPAINTER) ../../libkarboncommon.la
-karbon_insertknotsplugin_la_LDFLAGS = -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -L../../../lib/kofficeui/.libs/ -lkofficeui -L../../../lib/kofficecore/.libs/ -lkofficecore -L../../../lib/kopainter/.libs/ -lkopainter $(all_libraries) -module $(KDE_PLUGIN)
+karbon_insertknotsplugin_la_LDFLAGS = -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio $(all_libraries) -module $(KDE_PLUGIN)
partpluginsdir = $(kde_datadir)/karbon/kpartplugins
partplugins_DATA = insertknotsplugin.rc