summaryrefslogtreecommitdiffstats
path: root/kexi/plugins/queries/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kexi/plugins/queries/Makefile.am')
-rw-r--r--kexi/plugins/queries/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/kexi/plugins/queries/Makefile.am b/kexi/plugins/queries/Makefile.am
index 1b1052de..5dbb14f6 100644
--- a/kexi/plugins/queries/Makefile.am
+++ b/kexi/plugins/queries/Makefile.am
@@ -5,13 +5,16 @@ kde_module_LTLIBRARIES = kexihandler_query.la
kexihandler_query_la_SOURCES = kexiquerypart.cpp kexiquerydesignersql.cpp \
kexiquerydesignersqlhistory.cpp kexiquerydesignerguieditor.cpp \
kexiqueryview.cpp
-kexihandler_query_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) $(VER_INFO) -module -no-undefined -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -lkparts -L../../../lib/kofficecore/.libs/ -lkofficecore -L../../../lib/kofficeui/.libs/ -lkofficeui -L../../../lib/store/.libs/ -lkstore -L../../../kexi/kexidb/.libs/ -lkexidb -L../../../kexi/kexiutils/.libs/ -lkexiutils -L../../../kexi/kexidb/parser/.libs/ -lkexidbparser
-kexihandler_query_la_LIBADD = ../../core/libkexicore.la \
+kexihandler_query_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) $(VER_INFO) -module -no-undefined -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -lkparts
+kexihandler_query_la_LIBADD = $(KOFFICE_LIBS) ../../core/libkexicore.la \
$(top_builddir)/kexi/kexidb/libkexidb.la \
$(top_builddir)/kexi/widget/libkexiextendedwidgets.la \
$(top_builddir)/kexi/widget/tableview/libkexidatatable.la \
$(top_builddir)/kexi/widget/relations/libkexirelationsview.la \
- $(top_builddir)/lib/koproperty/libkoproperty.la
+ $(top_builddir)/lib/koproperty/libkoproperty.la \
+ ../../../kexi/kexidb/libkexidb.la \
+ ../../../kexi/kexiutils/libkexiutils.la \
+ ../../../kexi/kexidb/parser/libkexidbparser.la
INCLUDES= -I$(top_srcdir)/kexi/core -I$(top_srcdir)/kexi \
-I$(top_srcdir)/kexi/widget -I$(top_srcdir)/kexi/widget/tableview \