summaryrefslogtreecommitdiffstats
path: root/lib/kformula/fonts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/kformula/fonts/CMakeLists.txt')
-rw-r--r--lib/kformula/fonts/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/lib/kformula/fonts/CMakeLists.txt b/lib/kformula/fonts/CMakeLists.txt
new file mode 100644
index 00000000..74379d97
--- /dev/null
+++ b/lib/kformula/fonts/CMakeLists.txt
@@ -0,0 +1,18 @@
+###############################################################################
+# Trinity KOffice #
+# --------------- #
+# This file is licensed under the terms of GNU GPL v3 or later. #
+# Improvements and feedback are welcome. #
+###############################################################################
+
+### Data ######################################################################
+set(FONTDIR "${DATA_INSTALL_DIR}/kformula/fonts")
+install(
+ FILES cmex10.ttf Arev.ttf ArevIt.ttf ArevBd.ttf ArevBI.ttf
+ DESTINATION ${FONTDIR}
+)
+
+install(CODE "execute_process(COMMAND mkfontscale \$ENV{DESTDIR}${FONTDIR})")
+install(CODE "execute_process(COMMAND mkfontdir \$ENV{DESTDIR}${FONTDIR})")
+
+# kate: indent-width 2; replace-tabs true; \ No newline at end of file