summaryrefslogtreecommitdiffstats
path: root/lib/koproperty/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/koproperty/Makefile.am')
-rw-r--r--lib/koproperty/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/lib/koproperty/Makefile.am b/lib/koproperty/Makefile.am
new file mode 100644
index 00000000..654debd3
--- /dev/null
+++ b/lib/koproperty/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = -I$(srcdir)/editors -I$(top_srcdir)/lib/kofficecore $(all_includes)
+
+lib_LTLIBRARIES = libkoproperty.la
+
+libkoproperty_la_LIBADD = $(LIB_KDEUI) ./editors/libkopropertyeditors.la
+libkoproperty_la_LDFLAGS = -no-undefined $(all_libraries) -version-info 2:0:0
+libkoproperty_la_SOURCES = property.cpp customproperty.cpp set.cpp editor.cpp \
+ editoritem.cpp factory.cpp widget.cpp
+
+METASOURCES = AUTO
+
+SUBDIRS = editors . test
+
+
+icondir = $(kde_datadir)/koffice/icons
+icon_ICON = button_no
+
+EXTRA_DIST = $(icon_ICON)
+
+messages:
+# $(EXTRACTRC) */*.rc */*.ui > rc.cpp
+ $(XGETTEXT) *.cpp editors/*.cpp -o $(podir)/koproperty.pot