summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2023-07-23 00:03:50 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2023-07-23 00:03:50 +0900
commitb89fb39eb964ec3d3ee65e18348ac3e78f3e64da (patch)
treef536b1a418f23f13f9b8ff0c1492161a6cc6dc15 /debian/rules
parent28a5e3a6b506535a9c16339544619abae01aedd4 (diff)
downloadkommando-b89fb39eb964ec3d3ee65e18348ac3e78f3e64da.tar.gz
kommando-b89fb39eb964ec3d3ee65e18348ac3e78f3e64da.zip
DEB: updated packaging files to TDE standard
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules130
1 files changed, 17 insertions, 113 deletions
diff --git a/debian/rules b/debian/rules
index dfbb638..a6797f1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,113 +1,17 @@
-#! /usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-
-config.status: configure
- dh_testdir
- $(MAKE) -f /usr/share/tquilt/tquilt.make patch
- sleep 1
-
- # aclocal.m4 and acinclude.m4 have too recent timestamps in the
- find . -name Makefile.in | xargs touch configure config.h.in
-
-
- # Add here commands to configure the package.
- CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --disable-rpath
-
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- # Add here commands to compile the package.
- $(MAKE)
- #docbook-to-man debian/kommando.sgml > kommando.1
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- -$(MAKE) distclean
- $(MAKE) -f /usr/share/tquilt/tquilt.make unpatch
- rm -f config.sub config.guess
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/kommando.
- $(MAKE) install DESTDIR=$(CURDIR)/debian/kommando
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples debian/kommandorc
-
- #moves the documentation the right place
- mkdir -p debian/kommando/usr/share/doc/kde
- mv debian/kommando/usr/share/doc/HTML debian/kommando/usr/share/doc/kde
- #fixing symlink
- rm -f debian/kommando/usr/share/doc/kde/HTML/en/kommando/common
- ln -s ../common debian/kommando/usr/share/doc/kde/HTML/en/kommando/common
-
- #no shared library
- rm debian/kommando/usr/lib/libkommando.so
-
-
- dh_strip
- dh_compress -X.docbook
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"