summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:44:03 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:44:16 +0200
commit83bcfc439a758154ba2961b1ae13baef438a50e3 (patch)
tree898cf9030dbc5c0954d809062ce805164cb2189f /translations/messages/CMakeLists.txt
parent3d949c2bf3b18741020cee2c5b0d8d72d0ac178c (diff)
downloadkompose-83bcfc439a758154ba2961b1ae13baef438a50e3.tar.gz
kompose-83bcfc439a758154ba2961b1ae13baef438a50e3.zip
Use common rules for build and install documentation and translations.r14.0.11
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a33469c0c9a542fd5e82b29ea132848c010c2623)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
deleted file mode 100644
index 75c89f8..0000000
--- a/translations/messages/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} NAME_WE )
- if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
- if( "${_po}" MATCHES "^([^/]*)/.*" )
- string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
- else( )
- set( _component "${PROJECT_NAME}" )
- endif( )
- tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
- endif( )
-endforeach( )