summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt19
1 files changed, 8 insertions, 11 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index dc6bb77..2ce6ef4 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,12 +1,9 @@
-#################################################
-#
-# (C) 2012 Golubev Alexander
-# fatzer2 (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
+# build translations if some are already available
-tde_auto_add_subdirectories( )
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )