summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am50
1 files changed, 0 insertions, 50 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 06300a5..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,50 +0,0 @@
-METASOURCES = AUTO
-
-messages:
- extractrc `find . -name \*.ui -o -name \*.rc` > rc.cpp
- $(XGETTEXT) --keyword=i18n *.cpp -o $(top_srcdir)/po/kopete_otr.pot
-
-INCLUDES = $(all_includes) -I$(kde_includes)/kopete -I$(kde_includes)/tde/kopete -I$(kde_includes)/kopete/ui -I$(kde_includes)/tde/kopete/ui
-
-kde_module_LTLIBRARIES = kcm_kopete_otr.la kopete_otr.la
-
-kopete_otr_la_SOURCES = otrplugin-factory.cpp
-
-
-kopete_otr_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries) $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) \
- -lkopete
-
-kcm_kopete_otr_la_SOURCES = kopete_otr.kcfgc otrpreferences.cpp otrprefs.ui
-
-kcm_kopete_otr_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) \
- $(all_libraries) -lkopete
-kcm_kopete_otr_la_LIBADD = libkotr.la -lotr $(LIB_TDEUTILS)
-
-service_DATA = kopete_otr.desktop
-servicedir = $(kde_servicesdir)
-
-kde_kcfg_DATA = kopete_otr.kcfg
-
-kcm_DATA = kopete_otr_config.desktop
-kcmdir = $(kde_servicesdir)/tdeconfiguredialog
-
-kopete_otr_la_LIBADD = libkotr.la -lotr
-
-noinst_HEADERS = otrguiclient.h otrlchatinterface.h otrlconfinterface.h \
- otrplugin.h otrpreferences.h otrprefs.h privkeypopup.h smppopup.h verifypopup.h
-
-
-rcdir = $(kde_datadir)/kopete_otr
-rc_DATA = otrchatui.rc otrui.rc
-
-lib_LTLIBRARIES = libkotr.la
-libkotr_la_LDFLAGS = $(all_libraries) $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI)
-libkotr_la_SOURCES = \
- kopete_otr.kcfgc otrguiclient.cpp otrplugin.cpp \
- otrlchatinterface.cpp otrlconfinterface.cpp \
- privkeypopup.cpp privkeypopupui.ui smppopup.cpp smppopupui.ui verifypopup.cpp \
- verifypopupui.ui
-libkotr_la_LIBADD = -lotr
-
-SUBDIRS = pics
-