summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0486258..06300a5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,8 +8,8 @@ INCLUDES = $(all_includes) -I$(kde_includes)/kopete -I$(kde_includes)/tde/kopete
kde_module_LTLIBRARIES = kcm_kopete_otr.la kopete_otr.la
-kopete_otr_la_SOURCES = kopete_otr.kcfgc otrguiclient.cpp otrplugin.cpp
-
+kopete_otr_la_SOURCES = otrplugin-factory.cpp
+
kopete_otr_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries) $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) \
-lkopete
@@ -39,7 +39,9 @@ rc_DATA = otrchatui.rc otrui.rc
lib_LTLIBRARIES = libkotr.la
libkotr_la_LDFLAGS = $(all_libraries) $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI)
-libkotr_la_SOURCES = otrlchatinterface.cpp otrlconfinterface.cpp \
+libkotr_la_SOURCES = \
+ kopete_otr.kcfgc otrguiclient.cpp otrplugin.cpp \
+ otrlchatinterface.cpp otrlconfinterface.cpp \
privkeypopup.cpp privkeypopupui.ui smppopup.cpp smppopupui.ui verifypopup.cpp \
verifypopupui.ui
libkotr_la_LIBADD = -lotr