summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..467a30b
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,69 @@
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/debian
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kpicosim (executable)
+
+tde_add_executable( ${PROJECT_NAME} AUTOMOC
+
+ SOURCES
+ main.cpp
+ kpicosim.cpp
+ codeeditor.cpp
+ ksimulator.cpp
+ kprocessorview.cpp
+ kserialview.cpp
+ kportview.cpp
+ kscratchpadview.cpp
+ kport.cpp
+ kexportdialog.cpp
+ cassembler.cpp
+ cinstruction.cpp
+ cpicoblaze.cpp
+ jtagdevice.cpp
+ kjtagdialog.cpp
+ jtag.cpp
+ jtagprogrammer.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons
+
+tde_install_icons( ${PROJECT_NAME} )
+
+
+##### other data
+
+install(
+ FILES kpicosimui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
+)
+
+install(
+ FILES psm.xml
+ DESTINATION ${DATA_INSTALL_DIR}/katepart/syntax
+)
+
+install(
+ FILES ${PROJECT_NAME}.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/Development
+)