summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-03-21 23:06:29 +0900
committerSlávek Banko <slavek.banko@axis.cz>2019-03-31 15:03:51 +0200
commit2d2d8bba9f492b479ffb0f577cd2b2f65edf4167 (patch)
treec4df57d8d4183bb5cfaf5c4f8806a99ffdc0e31b /CMakeLists.txt
parent2ec4f38c780d149285ebc780db163d521a6ba674 (diff)
downloadkpilot-2d2d8bba9f492b479ffb0f577cd2b2f65edf4167.tar.gz
kpilot-2d2d8bba9f492b479ffb0f577cd2b2f65edf4167.zip
Fixed support for tests in cmake.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 5ea733c60c8f6323cf94b726b997e8e22bca191f)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 543953b..4e6dc68 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,7 @@ include( CheckIncludeFile )
include( CheckFunctionExists )
include( CheckLibraryExists )
include( CheckSymbolExists )
-
+enable_testing( )
#### include our cmake modules ##################
@@ -73,6 +73,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( lib )
add_subdirectory( kpilot )
add_subdirectory( conduits )
+add_subdirectory( tests )
+
tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )