summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFabio Rossi <rossi.f@inwind.it>2018-12-17 17:07:38 +0100
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-12-18 23:07:58 +0900
commitb2f2ad0e05ab40538e6d66aa645a7ebbb70b1dab (patch)
treecb60a6a323e561cc9d035101f3057d0ae493f5cb /CMakeLists.txt
parente329f178315617454f482dc139db72e3515d505a (diff)
downloadkpowersave-b2f2ad0e05ab40538e6d66aa645a7ebbb70b1dab.tar.gz
kpowersave-b2f2ad0e05ab40538e6d66aa645a7ebbb70b1dab.zip
Avoid overriding user linker flags (LDFLAGS) for modules and shared libs
Signed-off-by: Fabio Rossi <rossi.f@inwind.it> (cherry picked from commit bbe58195462dafd01dfb034f1e53d157a795d95d)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 588ce0b..d0030b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,8 +47,8 @@ add_definitions(
)
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
-set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
-set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
##### source directories ########################