summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-05-21 16:18:26 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-26 15:02:33 +0200
commiteb30e07ba19e45de980c0f86e8b39078621023a5 (patch)
tree291987d8584f0aeefab59363b2aedd98e79c8e97 /src/CMakeLists.txt
parent970528b7299b0bd73b663e0b73eca25abb382c76 (diff)
downloadkscope-eb30e07ba19e45de980c0f86e8b39078621023a5.tar.gz
kscope-eb30e07ba19e45de980c0f86e8b39078621023a5.zip
Add a man page.
Move the kscope.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 and bug 2408. Delete empty folder templates. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit 368ee23e036f50097ed148eaedfbead308a7ff26)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 12efd27..ad91146 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -9,6 +9,7 @@ include_directories(
link_directories(
${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
)
tde_import( kate )
@@ -101,23 +102,21 @@ tde_add_executable( kscope AUTOMOC
##### icons
-tde_install_icons( kscope )
+tde_install_icons( ${PROJECT_NAME} )
##### other data
+tde_create_translated_desktop( ${PROJECT_NAME}.desktop )
+
install(
FILES kscopeui.rc kscope_config
- DESTINATION ${DATA_INSTALL_DIR}/kscope
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
)
install(
FILES file_ro.png file_rw.png file_save.png query_locked.png
query_unlocked.png tab_list.png call_graph.png called_tree.png
calling_tree.png bookmark.png
- DESTINATION ${DATA_INSTALL_DIR}/kscope/pics
-)
-
-install( FILES kscope.desktop
- DESTINATION ${APPS_INSTALL_DIR}/Development
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/pics
)