summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-02 15:34:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-02 15:34:54 +0200
commita9196e50f775efd50ee6f364736e1b7bf89774f9 (patch)
tree8884400fbcd6694075cee39cb5fcd1b2afe763db /src/CMakeLists.txt
parente0f2629d5af6ed5499917dc162b45c8f02dddb04 (diff)
downloadksensors-a9196e50f775efd50ee6f364736e1b7bf89774f9.tar.gz
ksensors-a9196e50f775efd50ee6f364736e1b7bf89774f9.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit eff7b7b0b2e31516eee78d922693abce6e8d3b38)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f841d12..99d7c03 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -50,12 +50,9 @@ install(
DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
)
-install(
- FILES ${PROJECT_NAME}.desktop
- DESTINATION ${AUTOSTART_INSTALL_DIR}
-)
+tde_create_translated_desktop( ${PROJECT_NAME}.desktop )
install(
- FILES ${PROJECT_NAME}.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.desktop
+ DESTINATION ${AUTOSTART_INSTALL_DIR}
)