summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-09-30 11:03:15 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-10-01 17:16:10 +0900
commit6726e2fbb9c2cfc27bc67e7793863bc036b55944 (patch)
treecd98714f8509e774befe0def178a03ec1582ef85 /po/CMakeLists.txt
parent61254b9781405072cc10e9e3a57fa02460139a29 (diff)
downloadkshowmail-6726e2fbb9c2cfc27bc67e7793863bc036b55944.tar.gz
kshowmail-6726e2fbb9c2cfc27bc67e7793863bc036b55944.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty folder templates. Delete rpm stuff (kshowmail.spec and build-kshowmail folder). Rework of the README and AUTHORS files. Add BUGS file. Move the kshowmail.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 and bug 2408. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit e167d15409204539a0fa3a5b7260ca090192d6fa)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 597c341..75c89f8 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,5 +1,14 @@
-file( GLOB _srcs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-if( _srcs )
- tde_create_translation( LANG auto OUTPUT_NAME ${PROJECT_NAME} )
-endif( )
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )