summaryrefslogtreecommitdiffstats
path: root/extras/shutdown/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-10 03:24:07 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-10 03:24:24 +0200
commit8e674b278cd953c8d673bcd1dfcb28049bc3f664 (patch)
tree0de0a56530bd186f111f9bce319bffb1bc817f63 /extras/shutdown/CMakeLists.txt
parentb06708f5eb7c196b54bc9a3e86308da6b274d685 (diff)
downloadkshutdown-8e674b278cd953c8d673bcd1dfcb28049bc3f664.tar.gz
kshutdown-8e674b278cd953c8d673bcd1dfcb28049bc3f664.zip
Simplify CMake rules for desktop file translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 33c97fa091a67fbfcaae19b388c56a931bfca72a)
Diffstat (limited to 'extras/shutdown/CMakeLists.txt')
-rw-r--r--extras/shutdown/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/extras/shutdown/CMakeLists.txt b/extras/shutdown/CMakeLists.txt
index 68be21c..e76cfe3 100644
--- a/extras/shutdown/CMakeLists.txt
+++ b/extras/shutdown/CMakeLists.txt
@@ -1,9 +1,7 @@
file( GLOB _files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} .directory *.desktop )
-foreach( _source ${_files} )
- tde_create_translated_desktop(
- SOURCE ${_source}
- DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras/shutdown
- PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/extras
- )
-endforeach()
+tde_create_translated_desktop(
+ SOURCE ${_files}
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras/shutdown
+ PO_DIR extras
+)