summaryrefslogtreecommitdiffstats
path: root/kshutdownlockout/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kshutdownlockout/Makefile.am')
-rw-r--r--kshutdownlockout/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kshutdownlockout/Makefile.am b/kshutdownlockout/Makefile.am
new file mode 100644
index 0000000..7fd6b25
--- /dev/null
+++ b/kshutdownlockout/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kshutdownlockout_panelapplet.la
+
+kshutdownlockout_panelapplet_la_SOURCES = lockout.cpp
+kshutdownlockout_panelapplet_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+kshutdownlockout_panelapplet_la_LIBADD = $(LIB_KSYCOCA)
+
+noinst_HEADERS = lockout.h
+
+lnkdir = $(kde_datadir)/kicker/applets
+lnk_DATA = kshutdownlockout.desktop
+
+EXTRA_DIST = $(lnk_DATA)