summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-03 02:39:22 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-03 02:39:22 +0200
commit460b0273772f313ff533ba655ccaa11cf7acef5c (patch)
tree9ee16960767f394dd426921f86ae1a710301772d /src/CMakeLists.txt
parent51efb685369b4126eeb67225b7a775f9bc2ad66d (diff)
downloadksplash-engine-moodin-460b0273772f313ff533ba655ccaa11cf7acef5c.tar.gz
ksplash-engine-moodin-460b0273772f313ff533ba655ccaa11cf7acef5c.zip
Add the ability to translate:
+ Catalog for strings in the plugin. + Desktop file translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7ad6a22..e635036 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,4 +1,4 @@
-add_subdirectory( themes )
+tde_conditional_add_subdirectory( BUILD_THEMES themes )
include_directories(
${CMAKE_BINARY_DIR}
@@ -36,7 +36,7 @@ tde_add_kpart( ksplashmoodin AUTOMOC
##### other data
-install(
- FILES ksplashmoodin.desktop
+tde_create_translated_desktop(
+ SOURCE ksplashmoodin.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
)