summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..7ad6a22
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,42 @@
+add_subdirectory( themes )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TDE_INCLUDE_DIR}/ksplash
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### ksplashmoodin (kpart)
+
+tde_add_kpart( ksplashmoodin AUTOMOC
+
+ SOURCES
+ thememoodin.cpp
+ effectwidget.cpp
+ cache.cpp
+ magiclabel.cpp
+ scaler.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ ksplashthemes
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES ksplashmoodin.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)