summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..05543f9
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = $(all_includes) -I$(kde_includes)/ksplash
+
+kde_module_LTLIBRARIES = ksplashmoodin.la
+
+ksplashmoodin_la_SOURCES = thememoodin.cpp effectwidget.cpp cache.cpp magiclabel.cpp scaler.cpp
+ksplashmoodin_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -module $(KDE_PLUGIN)
+ksplashmoodin_la_LIBADD = $(LIB_KDEUI) -lksplashthemes
+
+METASOURCES = AUTO
+
+noinst_HEADERS = thememoodin.h effectwidget.h cache.h magiclabel.h scaler.h
+
+servicesdir = $(kde_servicesdir)
+services_DATA = ksplashmoodin.desktop
+
+themeMoodinKDEdir = $(kde_datadir)/ksplash/Themes/MoodinKDE
+themeMoodinKDE_DATA = themes/MoodinKDE/*
+themeFingerPrintdir = $(kde_datadir)/ksplash/Themes/FingerPrint
+themeFingerPrint_DATA = themes/FingerPrint/*