summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2021-03-03 21:42:42 +0100
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-03-05 10:42:12 +0900
commit38c6a406f3b082bcd57edf1c477564d26a9cb6c8 (patch)
tree7c418ed8bff0857ac221ce748a576a57a2f08ddf /CMakeLists.txt
parent02835b2f5219a8eb8c6c9477bd6dd7ce7d54ac0e (diff)
downloadkstreamripper-38c6a406f3b082bcd57edf1c477564d26a9cb6c8.tar.gz
kstreamripper-38c6a406f3b082bcd57edf1c477564d26a9cb6c8.zip
Drop scons build support.
Deleted empty file ChangeLog. Update some cmake files with latest macros. Add basic cmake build instructions. Few cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit 48deaabecefea835f81c9e6e8ba73ee8881c314c)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b3a33a7..542bfe1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,7 +41,7 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
@@ -69,7 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )