summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-11-02 22:33:43 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-11-02 22:33:47 +0100
commit2c73ccdf45212ab2a43582955be0eff21c70f971 (patch)
tree4754dd610c96338dc39ca60e38a7e794ef6c6966 /CMakeLists.txt
parentf23df438132393cf20cb93f9922325dc49792573 (diff)
downloadktechlab-2c73ccdf45212ab2a43582955be0eff21c70f971.tar.gz
ktechlab-2c73ccdf45212ab2a43582955be0eff21c70f971.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd0d6c1..899ea46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )