summaryrefslogtreecommitdiffstats
path: root/microbe/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-10-12 15:43:57 +0200
committergregory guy <gregory-tde@laposte.net>2020-11-02 17:30:41 +0100
commita9c86866c380e503dd75797b5c2d129bfb622a9e (patch)
tree7f082c4dc920583aea947d773459d9d29b7b65ef /microbe/CMakeLists.txt
parent99525910c366e86d76dfeb818697220703578e8a (diff)
downloadktechlab-a9c86866c380e503dd75797b5c2d129bfb622a9e.tar.gz
ktechlab-a9c86866c380e503dd75797b5c2d129bfb622a9e.zip
Conversion to the cmake building system.
Added man pages taken from the Debian packaging system. Move the ktechlab.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 and bug 2408. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'microbe/CMakeLists.txt')
-rw-r--r--microbe/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/microbe/CMakeLists.txt b/microbe/CMakeLists.txt
new file mode 100644
index 0000000..4e8883a
--- /dev/null
+++ b/microbe/CMakeLists.txt
@@ -0,0 +1,31 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### microbe (executable)
+
+tde_add_executable( microbe AUTOMOC
+
+ SOURCES
+ btreebase.cpp btreenode.cpp main.cpp
+ traverser.cpp expression.cpp pic14.cpp
+ variable.cpp optimizer.cpp instruction.cpp
+ microbe.cpp parser.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)