summaryrefslogtreecommitdiffstats
path: root/libktorrent/interfaces/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libktorrent/interfaces/Makefile.am')
-rw-r--r--libktorrent/interfaces/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/libktorrent/interfaces/Makefile.am b/libktorrent/interfaces/Makefile.am
new file mode 100644
index 0000000..dca1a4a
--- /dev/null
+++ b/libktorrent/interfaces/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+METASOURCES = AUTO
+libinterfaces_la_LDFLAGS = $(all_libraries)
+noinst_LTLIBRARIES = libinterfaces.la
+noinst_HEADERS = plugin.h coreinterface.h guiinterface.h torrentinterface.h \
+ monitorinterface.h chunkdownloadinterface.h peerinterface.h torrentfileinterface.h \
+ filetreeitem.h filetreediritem.h logmonitorinterface.h ipblockinginterface.h \
+ trackerslist.h peersource.h exitoperation.h
+libinterfaces_la_SOURCES = plugin.cpp coreinterface.cpp guiinterface.cpp \
+ prefpageinterface.cpp torrentinterface.cpp monitorinterface.cpp chunkdownloadinterface.cpp \
+ peerinterface.cpp torrentfileinterface.cpp filetreeitem.cpp filetreediritem.cpp \
+ functions.cpp logmonitorinterface.cpp ipblockinginterface.cpp trackerslist.cpp \
+ peersource.cpp exitoperation.cpp
+
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)