summaryrefslogtreecommitdiffstats
path: root/src/modules/channelsjoin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/channelsjoin/Makefile.am')
-rw-r--r--src/modules/channelsjoin/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/modules/channelsjoin/Makefile.am b/src/modules/channelsjoin/Makefile.am
new file mode 100644
index 00000000..c9f8a78e
--- /dev/null
+++ b/src/modules/channelsjoin/Makefile.am
@@ -0,0 +1,20 @@
+###############################################################################
+# KVirc IRC client Makefile - 10.03.2000 Szymon Stefanek <stefanek@tin.it>
+################################################################################
+
+AM_CPPFLAGS = -I$(SS_TOPSRCDIR)/src/kvilib/include/ -I$(SS_TOPSRCDIR)/src/kvirc/include/ \
+$(SS_INCDIRS) $(SS_CPPFLAGS) -DGLOBAL_KVIRC_DIR=\"$(globalkvircdir)\"
+
+pluglib_LTLIBRARIES = libkvichannelsjoin.la
+
+libkvichannelsjoin_la_LDFLAGS = -module -avoid-version $(SS_LDFLAGS) $(SS_LIBDIRS)
+
+libkvichannelsjoin_la_SOURCES = libkvichannelsjoin.cpp channelsjoinwindow.cpp
+libkvichannelsjoin_la_LIBADD = $(SS_LIBLINK) ../../kvilib/build/libkvilib.la
+
+noinst_HEADERS= channelsjoinwindow.h
+
+m_%.moc: %.h
+ $(SS_QT_MOC) $< -o $@
+
+channelsjoinwindow.cpp: m_channelsjoinwindow.moc