summaryrefslogtreecommitdiffstats
path: root/src/modules/popupeditor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/popupeditor/Makefile.am')
-rw-r--r--src/modules/popupeditor/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/modules/popupeditor/Makefile.am b/src/modules/popupeditor/Makefile.am
new file mode 100644
index 00000000..a9e2f1d7
--- /dev/null
+++ b/src/modules/popupeditor/Makefile.am
@@ -0,0 +1,17 @@
+AM_CPPFLAGS = -I$(SS_TOPSRCDIR)/src/kvilib/include/ -I$(SS_TOPSRCDIR)/src/kvirc/include/ \
+$(SS_INCDIRS) $(SS_CPPFLAGS) -DGLOBAL_KVIRC_DIR=\"$(globalkvircdir)\"
+
+pluglib_LTLIBRARIES = libkvipopupeditor.la
+
+libkvipopupeditor_la_LDFLAGS = -module -avoid-version $(SS_LDFLAGS) $(SS_LIBDIRS)
+
+libkvipopupeditor_la_SOURCES = libkvipopupeditor.cpp popupeditor.cpp
+nodist_libkvipopupeditor_la_SOURCES = moc_popupeditor.cpp
+
+noinst_HEADERS = popupeditor.h
+libkvipopupeditor_la_LIBADD = $(SS_LIBLINK) ../../kvilib/build/libkvilib.la
+
+# noinst_HEADERS=
+
+moc_popupeditor.cpp: popupeditor.h
+ $(SS_QT_MOC) $< -o $@