summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-26 17:27:41 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-26 17:27:53 +0200
commit51943781497b9f9cd3f23a38ecb6e369e5a0694d (patch)
treec41f20badc553685257b32f3d7006c714dd1cf56 /CMakeLists.txt
parent6fb5d38d9e6042f0ef2edc5c3fb32c352eb47c7a (diff)
downloadkvkbd-51943781497b9f9cd3f23a38ecb6e369e5a0694d.tar.gz
kvkbd-51943781497b9f9cd3f23a38ecb6e369e5a0694d.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 6c7aa4829d4772c14483db99c8bb563e68f0178c)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7f4187d..cc2fe3d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files