summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-02-12 14:02:24 +0100
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-02-12 23:24:18 +0900
commitc8f152ab7e637d0bf13effdb09d7a095d171948f (patch)
tree84e399f9eb6d0c966ff79e44e004564b7fd19477 /CMakeLists.txt
parent6600b1e14df45104c08f0df8f3a86bd3ea2c91f0 (diff)
downloadkvkbd-c8f152ab7e637d0bf13effdb09d7a095d171948f.tar.gz
kvkbd-c8f152ab7e637d0bf13effdb09d7a095d171948f.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty file NEWS, TODO and ChangeLog. Delete empty folder "templates". Add detection for the XTest library. Move the kvkbd.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 . Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit 92482b762101fc6e18740ba34ffb688e77ea8cfa)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3f8266..d136d17 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks