summaryrefslogtreecommitdiffstats
path: root/part/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'part/CMakeLists.txt')
-rw-r--r--part/CMakeLists.txt74
1 files changed, 74 insertions, 0 deletions
diff --git a/part/CMakeLists.txt b/part/CMakeLists.txt
new file mode 100644
index 0000000..58e5261
--- /dev/null
+++ b/part/CMakeLists.txt
@@ -0,0 +1,74 @@
+add_subdirectory( pics )
+add_subdirectory( icons )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kxmleditorpart (shared)
+
+tde_add_library( kxmleditorpart SHARED AUTOMOC
+
+ SOURCES
+ dcopiface_part_ro.skel
+ kxesearchdialogbase.ui kxeprocinstrdialogbase.ui
+ kxespecprocinstrdialogbase.ui kxeelementdialogbase.ui
+ kxeattributedialogbase.ui kxechardatadialogbase.ui
+ kxeattachdialogbase.ui kxechoosestringdialogbase.ui
+ kxetreeviewsettingspage.ui kxenewfilesettingspage.ui
+ kxeprintsettingspage.ui kxearchiveextssettingspage.ui
+ kxetextviewsettingspage.ui kxetexteditordialogbase.ui
+ kxesearchdialog.cpp kxeprocinstrdialog.cpp
+ kxespecprocinstrdialog.cpp kxeelementdialog.cpp
+ kxeattributedialog.cpp kxechardatadialog.cpp
+ kxechoosestringdialog.cpp kxefilenewdialog.cpp
+ kxeconfiguration.cpp kxesettings.cpp
+ kxetreeviewsettings.cpp kxenewfilesettings.cpp
+ kxeprintsettings.cpp kxearchiveextssettings.cpp
+ kxetextviewsettings.cpp kxe_treeviewitem.cpp
+ kxe_treeview.cpp kxe_viewelement.cpp
+ kxe_viewattributes.cpp kxesyntaxhighlighter.cpp
+ kxetexteditordialog.cpp actions.cpp
+ qdom_add.cpp kxecommand.cpp
+ commands_file.cpp commands_edit.cpp
+ commands_insert.cpp kxmleditorpart.cpp
+ kxmleditorfactory.cpp dcopiface_part_ro.cpp
+ kxedocument.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ tdeparts-shared
+ tdeprint-shared
+
+ VERSION 1.0.0
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES
+ kxedocument.rc
+ kxmleditorpartEditUI.rc
+ kxmleditorpartBrowseUI.rc
+
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
+)
+
+install(
+ FILES kxmleditorpart.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)