summaryrefslogtreecommitdiffstats
path: root/test/unittest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/unittest/CMakeLists.txt')
-rw-r--r--test/unittest/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/unittest/CMakeLists.txt b/test/unittest/CMakeLists.txt
new file mode 100644
index 0000000..1efdef2
--- /dev/null
+++ b/test/unittest/CMakeLists.txt
@@ -0,0 +1,20 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/src
+ ${GTHREAD_INCLUDE_DIRS}
+)
+
+
+##### unittest (executable)
+
+tde_add_executable( unittest
+
+ SOURCES
+ libunit.c
+ LINK
+ caldav-static
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)