summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2019-10-09 14:34:13 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-10-11 14:44:23 +0200
commit9133221057cc24298c69ea3dc934d66bd92c9afe (patch)
tree4d76657c3f252999ee43966ebaef6d871d5e2189 /CMakeLists.txt
parent8a58243840fdf586ce6b1d85a8b7d526266eeca2 (diff)
downloadlibcarddav-9133221057cc24298c69ea3dc934d66bd92c9afe.tar.gz
libcarddav-9133221057cc24298c69ea3dc934d66bd92c9afe.zip
Conversion to the cmake building system.
rfc4791.pdf has been moved to the doc folder. carddav pc file has been moved to the src folder. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit e2b50ac8f07a0fd04ee7ad5f4ad72075fddad215)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt76
1 files changed, 76 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..2c484bc
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,76 @@
+############################################
+# #
+# Improvements and feedbacks are welcome #
+# #
+# This file is released under GPL >= 3 #
+# #
+############################################
+
+
+cmake_minimum_required( VERSION 2.8 )
+
+
+#### general package setup
+
+project( libcarddav )
+set( VERSION R14.1.0 )
+set( PACKAGE_VERSION 0.6.1 )
+
+
+#### include essential cmake modules
+
+include( FindPkgConfig )
+include( CheckFunctionExists )
+include( CheckSymbolExists )
+include( CheckIncludeFile )
+include( CheckLibraryExists )
+include( CheckCSourceCompiles )
+
+
+#### include our cmake modules
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+
+
+##### setup install paths
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+
+
+##### user requested modules
+
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+
+
+##### configure checks
+
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings
+
+add_definitions( -DHAVE_CONFIG_H )
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
+
+
+##### directories
+
+add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+
+
+##### write configure files
+
+configure_file( config.h.cmake config.h @ONLY )