summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in41
1 files changed, 35 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index e773857..ecaff4e 100644
--- a/configure.in
+++ b/configure.in
@@ -40,7 +40,7 @@ dnl Perform program name transformation
AC_ARG_PROGRAM
dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(libkdcraw-0.1.4, "3.5.9") dnl searches for some needed programs
+AM_INIT_AUTOMAKE(libkdcraw-0.1.9, "3.5.10") dnl searches for some needed programs
KDE_SET_PREFIX
@@ -81,14 +81,12 @@ AC_CHECK_PROG(PKGCONFIGFOUND, pkg-config,[yes])
# Library API version
# -----------------------------------------------------------------
-ABI_MAJOR=3
-VERSION_INFO="3:0:0"
+ABI_MAJOR=4
+VERSION_INFO="4:3:0"
AC_SUBST(ABI_MAJOR)
AC_SUBST(VERSION_INFO)
-KDCRAW_DIR="\$(libdir)/libkdcraw\$(ABI_MAJOR)"
-AC_SUBST(KDCRAW_DIR)
# AM_PROG_CC_C_O to avoid that automake complains for it
AM_PROG_CC_C_O
@@ -172,6 +170,29 @@ AC_COMPILE_IFELSE(
)
CPPFLAGS=$libkdcraw_kdemacros_cppflags
AC_LANG_POP(C++)
+
+# -----------------------------------------------------------------
+# enable OpenMP support to use parallelized code from LibRaw
+# (default: disabled). this mode speed-up demosaicing operations.
+# -----------------------------------------------------------------
+
+AC_MSG_CHECKING(whether to enable parallel demosaicing operation from LibRaw using openmp...)
+AC_ARG_ENABLE([openmp], [AC_HELP_STRING([--enable-openmp],
+ [enable openmp [default=disabled] ])],
+ if test $enableval = yes; then
+ [AC_MSG_RESULT(yes)]
+ [AC_DEFINE([USING_OPENMP], 1, [using openmp])]
+ USING_OPENMP=yes
+ [CXXFLAGS="$CXXFLAGS -fopenmp"]
+ [OPENMP_LDFLAGS=" -lgomp "]
+ fi
+ ,
+ [AC_MSG_RESULT(no)]
+ [AC_DEFINE([USING_OPENMP], 0, [using openmp])]
+ USING_OPENMP=no
+ [OPENMP_LDFLAGS=""]
+ )
+AC_SUBST(OPENMP_LDFLAGS)
KDE_CREATE_SUBDIRSLIST
AM_CONDITIONAL(libkexiv2_SUBDIR_included, test "x$libkexiv2_SUBDIR_included" = xyes)
AM_CONDITIONAL(libkipi_SUBDIR_included, test "x$libkipi_SUBDIR_included" = xyes)
@@ -179,9 +200,10 @@ AM_CONDITIONAL(libkdcraw_SUBDIR_included, test "x$libkdcraw_SUBDIR_included" = x
AM_CONDITIONAL(po_SUBDIR_included, test "x$po_SUBDIR_included" = xyes)
AC_CONFIG_FILES([ Makefile ])
AC_CONFIG_FILES([ libkdcraw/Makefile ])
-AC_CONFIG_FILES([ libkdcraw/dcraw/Makefile ])
AC_CONFIG_FILES([ libkdcraw/icons/Makefile ])
AC_CONFIG_FILES([ libkdcraw/libkdcraw/Makefile ])
+AC_CONFIG_FILES([ libkdcraw/libraw/Makefile ])
+AC_CONFIG_FILES([ libkdcraw/test/Makefile ])
AC_CONFIG_FILES([ po/Makefile ])
AC_CONFIG_FILES([ po/ca/Makefile ])
AC_CONFIG_FILES([ po/da/Makefile ])
@@ -197,6 +219,7 @@ AC_CONFIG_FILES([ po/nds/Makefile ])
AC_CONFIG_FILES([ po/nl/Makefile ])
AC_CONFIG_FILES([ po/pa/Makefile ])
AC_CONFIG_FILES([ po/pt/Makefile ])
+AC_CONFIG_FILES([ po/pt_BR/Makefile ])
AC_CONFIG_FILES([ po/sk/Makefile ])
AC_CONFIG_FILES([ po/sr/Makefile ])
AC_CONFIG_FILES([ po/sr@Latn/Makefile ])
@@ -221,6 +244,12 @@ else
echo "-- lcms found..................... YES"
fi
+if test "x$USING_OPENMP" != "xyes"; then
+ echo "-- compile with OpenMP support.... NO (Optional)"
+ all_tests=bad
+else
+ echo "-- compile with OpenMP support.... YES (Optional)"
+fi
# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure