summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:24:44 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-16 11:53:44 +0900
commita1ca108fb482d1e8cf9ec50165afe6a3669c9581 (patch)
tree13e412234d7317f4752654a6352fe5c2f99c8942 /CMakeLists.txt
parent166d8c53fac84b68712ab5ce4273afeb6b1cf079 (diff)
downloadlibkipi-a1ca108fb482d1e8cf9ec50165afe6a3669c9581.tar.gz
libkipi-a1ca108fb482d1e8cf9ec50165afe6a3669c9581.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit e4b517bb0b8290fb5e43719670c12f293731f08d)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e7c5a9..a977121 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )