summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrunge <runge>2005-06-18 16:47:48 +0000
committerrunge <runge>2005-06-18 16:47:48 +0000
commit7b933e170e04576873bb9bcd3f4d19c8ffbf83af (patch)
tree2653076b422a726baceb6574dabde6fdf4bcada8 /configure.ac
parent543e64d3c6fa79126be5a5ec5f214a1a96f87335 (diff)
downloadlibtdevnc-7b933e170e04576873bb9bcd3f4d19c8ffbf83af.tar.gz
libtdevnc-7b933e170e04576873bb9bcd3f4d19c8ffbf83af.zip
configure.ac: HP-UX and OSF1 no -R, x11vnc: second round of beta-testing fixes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 919f702..f134de5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -184,7 +184,12 @@ if test "x$with_jpeg" != "xno"; then
saved_LDFLAGS="$LDFLAGS"
CPPFLAGS="$CPPFLAGS -I$with_jpeg/include"
LDFLAGS="$LDFLAGS -L$with_jpeg/lib"
- if test "x$GCC" = "xyes"; then
+ uname_s=`(uname -s) 2>/dev/null`
+ if test "x$uname_s" = "xHP-UX"; then
+ :
+ elif test "x$uname_s" = "xOSF1"; then
+ :
+ elif test "x$GCC" = "xyes"; then
# this is not complete... in general a rat's nest.
LDFLAGS="$LDFLAGS -Xlinker -R$with_jpeg/lib"
else
@@ -229,7 +234,12 @@ if test "x$with_zlib" != "xno" -a "x$with_libz" != "xno"; then
saved_LDFLAGS="$LDFLAGS"
CPPFLAGS="$CPPFLAGS -I$with_zlib/include"
LDFLAGS="$LDFLAGS -L$with_zlib/lib"
- if test "x$GCC" = "xyes"; then
+ uname_s=`(uname -s) 2>/dev/null`
+ if test "x$uname_s" = "xHP-UX"; then
+ :
+ elif test "x$uname_s" = "xOSF1"; then
+ :
+ elif test "x$GCC" = "xyes"; then
LDFLAGS="$LDFLAGS -Xlinker -R$with_zlib/lib"
else
LDFLAGS="$LDFLAGS -R$with_zlib/lib"