summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authordscho <dscho>2004-12-01 23:06:56 +0000
committerdscho <dscho>2004-12-01 23:06:56 +0000
commit658b65ad0cc2045bf2c930c8ef2a2853a07ba6ee (patch)
tree51a7b1f153204de2c3bc423411d8f5b2f566c4f6 /configure.ac
parent7d3b1c9762b5f2878e9783677677cb2b3aa10e7e (diff)
downloadlibtdevnc-658b65ad0cc2045bf2c930c8ef2a2853a07ba6ee.tar.gz
libtdevnc-658b65ad0cc2045bf2c930c8ef2a2853a07ba6ee.zip
support MinGW32!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 77ee436..58fdd7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,7 +32,6 @@ fi
AH_TEMPLATE(FFMPEG, [Use ffmpeg (for vnc2mpg)])
AC_ARG_WITH(ffmpeg,
[ --with-ffmpeg=dir set ffmpeg home directory],,)
-#AM_DEFINE(FFMPEG, "$with_ffmpeg")
AC_SUBST(with_ffmpeg)
AM_CONDITIONAL(WITH_FFMPEG, test ! -z "$with_ffmpeg")
@@ -143,6 +142,13 @@ AM_CONDITIONAL(HAVE_LIBSDL, test "x$with_sdl" = "xyes")
AC_SUBST(SDL_CFLAGS)
AC_SUBST(SDL_LIBS)
+MINGW=`uname -s | grep MINGW 2>/dev/null`
+AM_CONDITIONAL(MINGW, test ! -z "$MINGW" )
+if test ! -z "$MINGW"; then
+ WSOCKLIB="-lws2_32"
+fi
+AC_SUBST(WSOCKLIB)
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/time.h sys/timeb.h syslog.h unistd.h])